Perl Crypt::PBKDF2 library with minimal dependencies

I’ve published a partially-compatible Crypt::PBKDF2 library with minimal dependencies on GitHub

Review would be both welcomed and appreciated.

Note that you should probably rather use the original library instead, unless you are running a very old Linux distribution. The official Crypt::PBKDF2 library requires Perl Moose, which isn’t available on old operating systems, which is the reason I’ve had to put this together. Sometimes you can’t just upgrade everything to the latest OS – it’s more complicated than that.